6 features failed of 9 features
17 scenarios failed of 46 scenarios
17 steps failed of 359

All Passed Failed

Suite: default

Feature: SVH Company

The SVH Company bundle should behave per specification.

Feature: SVH Display Ad

The SVH Display Ad bundle should behave per specification.

Feature: SVH Page

The SVH Page bundle should behave per specification.

Feature: SVH Parent Corporation

The SVH Parent Corporation bundle should behave per specification.

Feature: SVH Playlist

The SVH Playlist bundle should behave per specification.

Feature: SVH Smart Playlist

The SVH Smart Playlist bundle should behave per specification.

Feature: SVH Video

The SVH Video bundle should behave per specification.

Feature: SVH Video Ad

The SVH Video Ad bundle should behave per specification.

Feature: SVH Video Feed

The SVH Video Feed bundle should behave per specification.


Feature: SVH Company

The SVH Company bundle should behave per specification.

  • Given I am logged in as a user with the "administrator" role
  • When I visit "admin/config/search/path/patterns"
  • Then the "pathauto_node_company_pattern" field should contain ""
  • Given I am logged in as a user with the "administrator" role
  • When I go to "admin/structure/types/manage/company"
  • Then the "name" field should contain "Company"
  • And the "title_label" field should contain "Name"
  • Then the "node_options[status]" checkbox should be checked
  • Then the "node_options[promote]" checkbox should be checked
  • Then the "node_options[sticky]" checkbox should not be checked
  • Then the "node_options[revision]" checkbox should not be checked
  • Then the "node_submitted" checkbox should be checked
  • Given I am on "/login"
  • And I fill in "edit-name" with "Administrator [autotest]"
  • And I fill in "edit-pass" with "4testing"
  • And I press "Login"
  • Then I should see "Welcome"
  • When I go to "node/add/company"
  • Then I should see an "#edit-title" element
  • And I should see an "#edit-field-url" element
  • And I should see an "#edit-field-logo" element
  • And I should see an "#edit-field-liverail-publisher-id" element
  • And I should see an "#edit-field-liverail-partner-id" element
  • And I should see an "#edit-field-autoplay" element
  • And I should see an "#edit-field-rollover-for-sound" element
  • And I should see an "#edit-field-play-volume" element
  • And I should see an "#edit-field-publish-to-youtube" element
  • And I should see an "#edit-field-youtube-channel" element
  • And I fill in the following:

    | Name * | A Typical company [autotest] |

  • When I press "Save"
  • Then I should see "A Typical company [autotest]"

    (The text "A Typical company [autotest]" was not found anywhere in the text of the current page.)

Feature: SVH Display Ad

The SVH Display Ad bundle should behave per specification.

  • Given I am logged in as a user with the "administrator" role
  • When I visit "admin/config/search/path/patterns"
  • Then the "pathauto_node_display_ad_pattern" field should contain ""
  • Given I am logged in as a user with the "administrator" role
  • When I go to "admin/structure/types/manage/display-ad"
  • Then the "name" field should contain "Display Ad"
  • Then the "title_label" field should contain "Title"
  • Then the "node_options[status]" checkbox should be checked
  • Then the "node_options[promote]" checkbox should be checked
  • Then the "node_options[sticky]" checkbox should not be checked
  • Then the "node_options[revision]" checkbox should not be checked
  • Then the "node_submitted" checkbox should be checked
  • Given I am logged in as a user with the "administrator" role
  • When I visit "/node/add/display-ad"
  • Then I should see an "#edit-title" element
  • Then I should see an "#edit-body" element
  • Then I should see an "#edit-field-ad-tag-url" element
  • And I fill in the following:

    | Title * | A Typical display_ad [autotest] |
    | Body | Interactively engage world-class infrastructures rather than efficient benefits. Continually aggregate interoperable technology before an expanded array of information. Continually aggregate performance based processes for revolutionary information. Phosfluorescently innovate. |

  • When I press "Save"
  • Then I should see "A Typical display_ad [autotest]"
  • And I should see "Interactively engage world-class infrastructures rather than efficient benefits. Continually aggregate interoperable technology before an expanded array of information. Continually aggregate performance based processes for revolutionary information. Phosfluorescently innovate."

Feature: SVH Page

The SVH Page bundle should behave per specification.

  • Given I am logged in as a user with the "administrator" role
  • When I visit "admin/config/search/path/patterns"
  • Then the "pathauto_node_page_pattern" field should contain "[node:title]"
  • Given I am logged in as a user with the "administrator" role
  • When I go to "admin/structure/types/manage/page"
  • Then the "name" field should contain "page"
  • And the "title_label" field should contain "Title"
  • Then the "node_options[status]" checkbox should be checked
  • Then the "node_options[promote]" checkbox should not be checked
  • Then the "node_options[sticky]" checkbox should not be checked
  • Then the "node_options[revision]" checkbox should not be checked
  • Then the "node_submitted" checkbox should not be checked
  • Given I am logged in as a user with the "administrator" role
  • When I visit "/node/add/page"
  • Then I should see an "#edit-title" element
  • Then I should see an "#edit-body" element
  • Then I should see the heading "Create Page"
  • And I fill in the following:

    | Title * | A Typical page [autotest] |
    | Body | Aliquam placerat mauris sed pharetra eleifend. |

  • When I press "Save"
  • Then I should see "A Typical page [autotest]"
  • Then I should see "Aliquam placerat mauris sed pharetra eleifend."

Feature: SVH Parent Corporation

The SVH Parent Corporation bundle should behave per specification.

  • Given I am logged in as a user with the "administrator" role
  • When I visit "admin/config/search/path/patterns"
  • Then the "pathauto_node_parent_corporation_pattern" field should contain ""
  • Given I am logged in as a user with the "administrator" role
  • When I go to "admin/structure/types/manage/parent-corporation"
  • Then the "name" field should contain "Parent Corporation"
  • Then the "title_label" field should contain "Name"
  • Then the "node_options[status]" checkbox should be checked
  • Then the "node_options[promote]" checkbox should be checked
  • Then the "node_options[sticky]" checkbox should not be checked
  • Then the "node_options[revision]" checkbox should not be checked
  • Then the "node_submitted" checkbox should be checked
  • Given I am logged in as a user with the "administrator" role
  • When I visit "/node/add/parent-corporation"
  • Then I should see an "#edit-title" element
  • Then I should see an "#edit-field-logo-und-0-upload" element
  • And I fill in the following:

    | Name * | A Typical parent_corporation [autotest] |

  • When I press "Save"
  • Then I should see "A Typical parent_corporation [autotest]"
  • Given I am on "/login"
  • And I fill in "edit-name" with "Site-admin [autotest]"
  • And I fill in "edit-pass" with "4testing"
  • And I press "Login"
  • Then I should see "Welcome"
  • When I visit "/node/add/parent-corporation"

    (Current response status code is 403, but 200 expected.)

  • Then I should see an "#edit-title" element
  • Then I should see an "#edit-field-logo-und-0-upload" element
  • And I fill in the following:

    | Name * | A Typical parent_corporation [autotest] |

  • When I press "Save"
  • Then I should see "A Typical parent_corporation [autotest]"

Feature: SVH Playlist

The SVH Playlist bundle should behave per specification.

  • Given I am logged in as a user with the "administrator" role
  • When I visit "admin/config/search/path/patterns"
  • Then the "pathauto_node_playlist_pattern" field should contain "playlist/[node:title]"
  • Given I am logged in as a user with the "administrator" role
  • When I go to "admin/structure/types/manage/playlist"
  • Then the "name" field should contain "Playlist"
  • Then the "title_label" field should contain "Name"
  • Then the "node_options[status]" checkbox should not be checked
  • Then the "node_options[promote]" checkbox should not be checked
  • Then the "node_options[sticky]" checkbox should not be checked
  • Then the "node_options[revision]" checkbox should be checked
  • Then the "node_submitted" checkbox should be checked
  • Given I am logged in as a user with the "administrator" role
  • When I visit "node/add/playlist"
  • Then I should see an "#edit-title" element
  • And I fill in the following:

    | Name * | A Typical admin playlist [autotest] |

  • When I press "Create Playlist and Add Videos"
  • Then I should see "A Typical admin playlist [autotest]"
  • And I should see an ".save-playlist" element
  • And I should see an ".done-playlist" element
  • And I publish the node with the title "A Typical admin playlist [autotest]"
  • Given I am on "login"
  • And I fill in "edit-name" with "Group-admin [autotest]"
  • And I fill in "edit-pass" with "4testing"
  • And I press "Login"
  • Then I should see "Welcome"
  • When I visit "node/add/playlist"

    (Current response status code is 403, but 200 expected.)

  • Then I should see an "#edit-title" element
  • And I fill in the following:

    | Name * | A Typical group admin playlist [autotest] |

  • When I press "Create Playlist and Add Videos"
  • Then I should see "A Typical group admin playlist [autotest]"
  • And I should see an ".save-playlist" element
  • And I should see an ".done-playlist" element
  • And I publish the node with the title "A Typical group admin playlist [autotest]"
  • Given I am on "login"
  • And I fill in "edit-name" with "Site-admin [autotest]"
  • And I fill in "edit-pass" with "4testing"
  • And I press "Login"
  • Then I should see "Welcome"
  • When I visit "node/add/playlist"
  • Then I should see an "#edit-title" element
  • And I fill in the following:

    | Name * | A Typical site admin playlist [autotest] |

  • When I press "Create Playlist and Add Videos"
  • Then I should see "A Typical site admin playlist [autotest]"
  • And I should see an ".save-playlist" element
  • And I should see an ".done-playlist" element
  • Given I am on "login"
  • And I fill in "edit-name" with "Group-editor [autotest]"
  • And I fill in "edit-pass" with "4testing"
  • And I press "Login"
  • Then I should see "Welcome"
  • When I visit "node/add/playlist"
  • Then I should see an "#edit-title" element
  • And I fill in the following:

    | Name * | A Typical group editor playlist [autotest] |

  • When I press "Create Playlist and Add Videos"
  • Then I should see "A Typical group editor playlist [autotest]"
  • And I should see an ".save-playlist" element
  • And I should see an ".done-playlist" element
  • Given I am on "login"
  • And I fill in "edit-name" with "Publisher [autotest]"
  • And I fill in "edit-pass" with "4testing"
  • And I press "Login"
  • Then I should see "Welcome"
  • When I visit "node/add/playlist"
  • Then I should see an "#edit-title" element
  • And I fill in the following:

    | Name * | A Typical publisher playlist [autotest] |

  • When I press "Create Playlist and Add Videos"
  • Then I should see "A Typical publisher playlist [autotest]"
  • And I should see an ".save-playlist" element
  • And I should see an ".done-playlist" element
  • Given I am logged in as a user with the "administrator" role
  • When I go to "tpgv-admin/playlists"
  • And I fill in "search" with "A Typical"
  • And I press "Search Playlists"
  • Then I should not see "A Typical admin playlist [autotest]"
  • And I should not see "A Typical site admin playlist [autotest]"
  • And I should see "A Typical group admin playlist [autotest]"

    (The text "A Typical group admin playlist [autotest]" was not found anywhere in the text of the current page.)

  • And I should see "A Typical group editor playlist [autotest]"
  • And I should see "A Typical publisher playlist [autotest]"
  • Given I am on "/login"
  • And I fill in "edit-name" with "Publisher [autotest]"
  • And I fill in "edit-pass" with "4testing"
  • And I press "Login"
  • Then I should see "Welcome"
  • When I go to "tpgv-admin/playlists"
  • And I fill in "search" with "A Typical"
  • And I press "Search Playlists"
  • Then I should not see "A Typical admin playlist [autotest]"
  • And I should not see "A Typical site admin playlist [autotest]"
  • And I should see "A Typical publisher playlist [autotest]"

    (The text "A Typical publisher playlist [autotest]" was not found anywhere in the text of the current page.)

  • And I should see "A Typical group admin playlist [autotest]"
  • And I should see "A Typical group editor playlist [autotest]"

Feature: SVH Smart Playlist

The SVH Smart Playlist bundle should behave per specification.

  • Given I am logged in as a user with the "administrator" role
  • When I visit "admin/config/search/path/patterns"
  • Then the "pathauto_node_smart_playlist_pattern" field should contain "smart-playlist/[node:title]"
  • Given I am logged in as a user with the "administrator" role
  • When I go to "admin/structure/types/manage/smart-playlist"
  • Then the "name" field should contain "Smart Playlist"
  • Then the "title_label" field should contain "Playlist Title"
  • Then the "node_options[status]" checkbox should be checked
  • Then the "node_options[promote]" checkbox should not be checked
  • Then the "node_options[sticky]" checkbox should not be checked
  • Then the "node_options[revision]" checkbox should not be checked
  • Then the "node_submitted" checkbox should not be checked
  • Given I am logged in as a user with the "administrator" role
  • When I visit "node/add/smart-playlist"
  • Then I should see an "#edit-title" element
  • And I fill in the following:

    | Playlist Title * | A Typical admin Smart Playlist [autotest] |

  • When I press "Save and Preview"

    ([curl] 28: Operation timed out after 240000 milliseconds with 0 bytes received [url] http://www.tpgvadmin.com/node/add/smart-playlist)

  • Then I should see "A Typical admin Smart Playlist [autotest]"
  • And I publish the node with the title "A Typical admin Smart Playlist [autotest]"
  • Given I am on "login"
  • And I fill in "edit-name" with "Group-admin [autotest]"
  • And I fill in "edit-pass" with "4testing"
  • And I press "Login"
  • Then I should see "Welcome"
  • When I visit "node/add/smart-playlist"

    (Current response status code is 403, but 200 expected.)

  • Then I should see an "#edit-title" element
  • And I fill in the following:

    | Playlist Title * | A Typical group admin Smart Playlist [autotest] |

  • When I press "Save and Preview"
  • Then I should see "A Typical group admin Smart Playlist [autotest]"
  • And I publish the node with the title "A Typical group admin Smart Playlist [autotest]"
  • Given I am on "login"
  • And I fill in "edit-name" with "Site-admin [autotest]"
  • And I fill in "edit-pass" with "4testing"
  • And I press "Login"
  • Then I should see "Welcome"
  • When I visit "node/add/smart-playlist"
  • Then I should see an "#edit-title" element
  • And I fill in the following:

    | Playlist Title * | A Typical site admin Smart Playlist [autotest] |

  • When I press "Save and Preview"
  • Then I should see "A Typical site admin Smart Playlist [autotest]"
  • Given I am on "login"
  • And I fill in "edit-name" with "Group-editor [autotest]"
  • And I fill in "edit-pass" with "4testing"
  • And I press "Login"
  • Then I should see "Welcome"
  • When I visit "node/add/smart-playlist"
  • Then I should see an "#edit-title" element
  • And I fill in the following:

    | Playlist Title * | A Typical group editor Smart Playlist [autotest] |

  • When I press "Save and Preview"
  • Then I should see "A Typical group editor Smart Playlist [autotest]"
  • Given I am on "login"
  • And I fill in "edit-name" with "Publisher [autotest]"
  • And I fill in "edit-pass" with "4testing"
  • And I press "Login"
  • Then I should see "Welcome"
  • When I visit "node/add/smart-playlist"
  • Then I should see an "#edit-title" element
  • And I fill in the following:

    | Playlist Title * | A Typical publisher Smart Playlist [autotest] |

  • When I press "Save and Preview"
  • Then I should see "A Typical publisher Smart Playlist [autotest]"
  • Given I am logged in as a user with the "administrator" role
  • When I go to "tpgv-admin/smart-playlists"
  • And I fill in "search" with "A Typical"
  • And I press "Search Smart Playlists"
  • Then I should not see "A Typical admin smart playlist [autotest]"
  • And I should not see "A Typical site admin smart playlist [autotest]"
  • And I should see "A Typical group admin smart playlist [autotest]"

    (The text "A Typical group admin smart playlist [autotest]" was not found anywhere in the text of the current page.)

  • And I should see "A Typical group editor smart playlist [autotest]"
  • And I should see "A Typical publisher smart playlist [autotest]"
  • Given I am on "/login"
  • And I fill in "edit-name" with "Publisher [autotest]"
  • And I fill in "edit-pass" with "4testing"
  • And I press "Login"
  • Then I should see "Welcome"
  • When I go to "tpgv-admin/smart-playlists"
  • And I fill in "search" with "A Typical"
  • And I press "Search Smart Playlists"
  • Then I should not see "A Typical admin smart playlist [autotest]"
  • And I should not see "A Typical site admin smart playlist [autotest]"
  • And I should see "A Typical publisher smart playlist [autotest]"

    (The text "A Typical publisher smart playlist [autotest]" was not found anywhere in the text of the current page.)

  • And I should see "A Typical group admin smart playlist [autotest]"
  • And I should see "A Typical group editor smart playlist [autotest]"

Feature: SVH Video

The SVH Video bundle should behave per specification.

  • Given I am logged in as a user with the "administrator" role
  • When I visit "admin/config/search/path/patterns"
  • Then the "pathauto_node_video_pattern" field should contain ""
  • Given I am logged in as a user with the "administrator" role
  • When I go to "admin/structure/types/manage/video"
  • Then the "name" field should contain "Video"
  • Then the "title_label" field should contain "Title"
  • Then the "node_options[status]" checkbox should not be checked
  • Then the "node_options[promote]" checkbox should not be checked
  • Then the "node_options[sticky]" checkbox should not be checked
  • Then the "node_options[revision]" checkbox should not be checked
  • Then the "node_submitted" checkbox should not be checked
  • Given I am on "/login"
  • And I fill in "edit-name" with "Administrator [autotest]"
  • And I fill in "edit-pass" with "4testing"
  • And I press "Login"
  • Then I should see "Welcome"
  • When I visit "/node/add/video"
  • Then should see an "#edit-field-video" element
  • And I should see an "#edit-title" element
  • And I should see an "#edit-body" element
  • And I should see an "#edit-field-video-tags" element
  • And I should see an "#edit-tpgv-thumbnail-upload" element
  • And I should see an "#edit-field-video-syndicatable-und" element
  • Then I attach the file "../features/bootstrap/resources/TestVideo.mp4" to "files[field_video_und_0]"
  • And I press "Upload"
  • Then I should see "TestVideo.mp4"
  • And I should see "1.01 MB"
  • And I fill in the following:

    | Title * | A Typical admin video [autotest] |
    | Description | Interactively engage world-class infrastructures rather than efficient benefits. Continually aggregate interoperable technology before an expanded array of information. Continually aggregate performance based processes for revolutionary information. Phosfluorescently innovate. |
    | Tags * | Test |

  • When I press "Create Video"
  • Then I should see "Transcoding job was successfully submitted"

    (The text "Transcoding job was successfully submitted" was not found anywhere in the text of the current page.)

  • When I am on "content/typical-admin-video-autotest"
  • Then I should see "A Typical admin video [autotest]"
  • And I should see "Interactively engage world-class infrastructures rather than efficient benefits. Continually aggregate interoperable technology before an expanded array of information. Continually aggregate performance based processes for revolutionary information. Phosfluorescently innovate."
  • And I publish the node with the title "A Typical admin video [autotest]"
  • Given I am on "/login"
  • And I fill in "edit-name" with "Group-admin [autotest]"
  • And I fill in "edit-pass" with "4testing"
  • And I press "Login"
  • Then I should see "Welcome"
  • When I visit "/node/add/video"

    (Current response status code is 403, but 200 expected.)

  • Then should see an "#edit-field-video" element
  • And I should see an "#edit-title" element
  • And I should see an "#edit-body" element
  • And I should see an "#edit-field-video-tags" element
  • And I should see an "#edit-tpgv-thumbnail-upload" element
  • And I should see an "#edit-field-video-syndicatable-und" element
  • Then I attach the file "../features/bootstrap/resources/TestVideo.mp4" to "files[field_video_und_0]"
  • And I press "Upload"
  • Then I should see "TestVideo.mp4"
  • And I should see "1.01 MB"
  • And I fill in the following:

    | Title * | A Typical group admin video [autotest] |
    | Description | Interactively engage world-class infrastructures rather than efficient benefits. Continually aggregate interoperable technology before an expanded array of information. Continually aggregate performance based processes for revolutionary information. Phosfluorescently innovate. |
    | Tags * | Test |

  • And I uncheck the box "edit-field-video-syndicatable-und"
  • When I press "Create Video"
  • Then I should see "Transcoding job was successfully submitted"
  • When I am on "content/typical-group-admin-video-autotest"
  • Then I should see "You are not authorized to access this page."
  • Given I am on "/login"
  • And I fill in "edit-name" with "Site-admin [autotest]"
  • And I fill in "edit-pass" with "4testing"
  • And I press "Login"
  • Then I should see "Welcome"
  • When I visit "/node/add/video"

    (Current response status code is 403, but 200 expected.)

  • Then should see an "#edit-field-video" element
  • And I should see an "#edit-title" element
  • And I should see an "#edit-body" element
  • And I should see an "#edit-field-video-tags" element
  • And I should see an "#edit-tpgv-thumbnail-upload" element
  • And I should see an "#edit-field-video-syndicatable-und" element
  • Then I attach the file "../features/bootstrap/resources/TestVideo.mp4" to "files[field_video_und_0]"
  • And I press "Upload"
  • Then I should see "TestVideo.mp4"
  • And I should see "1.01 MB"
  • And I fill in the following:

    | Title * | A Typical site admin video [autotest] |
    | Description | Interactively engage world-class infrastructures rather than efficient benefits. Continually aggregate interoperable technology before an expanded array of information. Continually aggregate performance based processes for revolutionary information. Phosfluorescently innovate. |
    | Tags * | Test |

  • And I uncheck the box "edit-field-video-syndicatable-und"
  • When I press "Create Video"
  • Then I should see "Transcoding job was successfully submitted"
  • When I am on "content/typical-site-admin-video-autotest"
  • Then I should see "A Typical site admin video [autotest]"
  • And I should see "Interactively engage world-class infrastructures rather than efficient benefits. Continually aggregate interoperable technology before an expanded array of information. Continually aggregate performance based processes for revolutionary information. Phosfluorescently innovate."
  • Given I am on "/login"
  • And I fill in "edit-name" with "Group-editor [autotest]"
  • And I fill in "edit-pass" with "4testing"
  • And I press "Login"
  • Then I should see "Welcome"
  • When I visit "/node/add/video"

    (Current response status code is 403, but 200 expected.)

  • Then should see an "#edit-field-video" element
  • And I should see an "#edit-title" element
  • And I should see an "#edit-body" element
  • And I should see an "#edit-field-video-tags" element
  • And I should see an "#edit-tpgv-thumbnail-upload" element
  • And I should see an "#edit-field-video-syndicatable-und" element
  • Then I attach the file "../features/bootstrap/resources/TestVideo.mp4" to "files[field_video_und_0]"
  • And I press "Upload"
  • Then I should see "TestVideo.mp4"
  • And I should see "1.01 MB"
  • And I fill in the following:

    | Title * | A Typical group editor video [autotest] |
    | Description | Interactively engage world-class infrastructures rather than efficient benefits. Continually aggregate interoperable technology before an expanded array of information. Continually aggregate performance based processes for revolutionary information. Phosfluorescently innovate. |
    | Tags * | Test |

  • And I check the box "edit-field-video-syndicatable-und"
  • When I press "Create Video"
  • Then I should see "Transcoding job was successfully submitted"
  • When I am on "content/typical-group-editor-video-autotest"
  • Then I should see "You are not authorized to access this page."
  • Given I am on "/login"
  • And I fill in "edit-name" with "Contributor [autotest]"
  • And I fill in "edit-pass" with "4testing"
  • And I press "Login"
  • Then I should see "Welcome"
  • When I visit "/node/add/video"

    (Current response status code is 403, but 200 expected.)

  • Then should see an "#edit-field-video" element
  • And I should see an "#edit-title" element
  • And I should see an "#edit-body" element
  • And I should see an "#edit-field-video-tags" element
  • And I should see an "#edit-tpgv-thumbnail-upload" element
  • And I should not see an "#edit-field-video-syndicatable-und" element
  • Then I attach the file "../features/bootstrap/resources/TestVideo.mp4" to "files[field_video_und_0]"
  • And I press "Upload"
  • Then I should see "TestVideo.mp4"
  • And I should see "1.01 MB"
  • And I fill in the following:

    | Title * | A Typical contributor video [autotest] |
    | Description | Interactively engage world-class infrastructures rather than efficient benefits. Continually aggregate interoperable technology before an expanded array of information. Continually aggregate performance based processes for revolutionary information. Phosfluorescently innovate. |
    | Tags * | Test |

  • When I press "Create Video"
  • Then I should see "Transcoding job was successfully submitted"
  • When I am on "content/typical-contributor-video-autotest"
  • Then I should see "A Typical contributor video [autotest]"
  • Given I am logged in as a user with the "administrator" role
  • When I go to "video-search"
  • And I fill in "edit-keys" with "A Typical"
  • And I press "Search Videos"
  • Then I should see "A Typical admin video [autotest]"

    (The text "A Typical admin video [autotest]" was not found anywhere in the text of the current page.)

  • And I should see "A Typical group editor video [autotest]"
  • And I should see "A Typical group admin video [autotest]"
  • And I should see "A Typical site admin video [autotest]"
  • And I should see "A Typical contributor video [autotest]"
  • Given I am on "/login"
  • And I fill in "edit-name" with "Contributor [autotest]"
  • And I fill in "edit-pass" with "4testing"
  • And I press "Login"
  • Then I should see "Welcome"
  • When I go to "video-search"
  • And I fill in "edit-keys" with "A Typical"
  • And I press "Search Videos"
  • Then I should see "A Typical contributor video [autotest]"

    (The text "A Typical contributor video [autotest]" was not found anywhere in the text of the current page.)

  • And I should see "A Typical admin video [autotest]"
  • And I should not see "A Typical group editor video [autotest]"
  • And I should not see "A Typical group admin video [autotest]"
  • And I should not see "A Typical site admin video [autotest]"

Feature: SVH Video Ad

The SVH Video Ad bundle should behave per specification.

  • Given I am logged in as a user with the "administrator" role
  • When I visit "admin/config/search/path/patterns"
  • Then the "pathauto_node_video_ad_pattern" field should contain ""
  • Given I am logged in as a user with the "administrator" role
  • When I go to "admin/structure/types/manage/video-ad"
  • Then the "name" field should contain "Video Ad"
  • Then the "title_label" field should contain "Title"
  • Then the "node_options[status]" checkbox should be checked
  • Then the "node_options[promote]" checkbox should be checked
  • Then the "node_options[sticky]" checkbox should not be checked
  • Then the "node_options[revision]" checkbox should not be checked
  • Then the "node_submitted" checkbox should be checked
  • Given I am logged in as a user with the "administrator" role
  • When I visit "/node/add/video-ad"
  • Then I should see an "#edit-title" element
  • Then I should see an "#edit-body" element
  • Then I should see an "#edit-field-ad-tag-url" element
  • And I fill in the following:

    | Title * | A Typical video_ad [autotest] |
    | Body | Interactively engage world-class infrastructures rather than efficient benefits. Continually aggregate interoperable technology before an expanded array of information. Continually aggregate performance based processes for revolutionary information. Phosfluorescently innovate. |

  • When I press "Save"
  • Then I should see "A Typical video_ad [autotest]"
  • And I should see "Interactively engage world-class infrastructures rather than efficient benefits. Continually aggregate interoperable technology before an expanded array of information. Continually aggregate performance based processes for revolutionary information. Phosfluorescently innovate."

Feature: SVH Video Feed

The SVH Video Feed bundle should behave per specification.

  • Given I am logged in as a user with the "administrator" role
  • When I visit "admin/config/search/path/patterns"
  • Then the "pathauto_node_video_feed_pattern" field should contain ""
  • Given I am logged in as a user with the "administrator" role
  • When I go to "admin/structure/types/manage/video-feed"
  • Then the "name" field should contain "Video Feed"
  • Then the "title_label" field should contain "Name"
  • Then the "node_options[status]" checkbox should be checked
  • Then the "node_options[promote]" checkbox should not be checked
  • Then the "node_options[sticky]" checkbox should not be checked
  • Then the "node_options[revision]" checkbox should not be checked
  • Then the "node_submitted" checkbox should not be checked
  • Given I am logged in as a user with the "administrator" role
  • When I visit "/node/add/video-feed"
  • Then I should see an "#edit-title" element
  • Then I should see an "#edit-field-autopublish-on" element
  • And I fill in the following:

    | Name * | A Typical video_feed [autotest] |

  • When I press "Save"
  • Then I should see "A Typical video_feed [autotest]"

    (The text "A Typical video_feed [autotest]" was not found anywhere in the text of the current page.)